Is a PSCAD v5.0.0 License Compatible with Older Versions of PSCAD?

This article provides information on backwards compatibility for a PSCAD V5 license, for both lock-based and certificate licensing.

1. PSCAD V5 Lock-Based License

The following chart specifies how a PSCAD V5 lock-based license may be used with older versions of PSCAD.

V5 Lock-based license with Earlier PSCAD versions1.png (61 KB)

    Notes

  1. Licensing will work using the v5 lock, but it will not correctly be reported as being a PSCAD v5 lock license.

  2. User must upgrade to the Standalone License Manager 1.45 or better.

  3. Specifically supported with v4.2.1 (2007) with the 2020 Update installed.

Best Practices for Using PSCAD V5 Lock-Based Licensing

Please see this article for further details and information.


2. PSCAD V5 Certificate Licensing

The following chart specifies how a PSCAD V5 license certificate may be used with older versions of PSCAD.

V5 Certificate Licensing with Earlier PSCAD versions1.png (54 KB)

     Notes

  1. If using a PSCAD V5 certificate to run V5 and one of the supported X4 versions on a single machine, then V5 must be configured to share certificates with X4 as per Step 1 of this article.

  2. Since a V5 license cannot be used for these earlier versions, then a separate certificate will be required to run each of the V5 and X4 versions on a single machine, AND V5 must be configured to not share certificates with X4 as per this article.

  3. Not supported with Certificate Licensing.

Best Practices for Using PSCAD V5 Certificate Licensing

Please see this article for further details and information.

Back